Penn Place 700 Filter

  • Get the NEW AquariaCentral iOS app --> http://itunes.apple.com/app/id1227181058 // Android version will be out soon!

Bellaalers

AC Members
Original poster
May 19, 2020
8
0
1
61
I hope I'm in the right place, I have a Penn Place 700 Filter, had it about 2 months, after I cleaned it for the first time the water flow is half of what is was and it makes a humming noise. Can anyone help.
 

the loach

AC Members
Aug 6, 2018
1,009
505
120
So servicing the filter caused this, or was the issue there and cleaning didn't help?
 

dudley

Eheim User
Feb 9, 2005
1,444
167
66
Medina, Ohio
Real Name
Dee
It's possible that there is still air trapped in the filter since you recently cleaned it. Unplug the power cord and watch and see if any air bubbles rise up the output line, wait a couple minutes and plug the power cord back in. Watch the output flow to see if it has improved. You can also try tilting the canister a bit to see if any more air escapes from the filter.

If the above suggestions don't work for improving the filter flow, you will probably have to take the filter back apart and check that everything is in the correct position and try again. Don't forget to properly prime the filter with water before plugging the power cord back in to the wall outlet.
 

fishorama

AC Members
Jun 28, 2006
9,861
901
144
SF Bay area, CA
I haven't used that filter but if Dee's suggestions don't work & you have to take it apart be sure to clean the impeller & the place it goes into. A Q-tip or 2 used gently on all surfaces does the trick. Also make sure the quick connect (where the hoses come off) is seated well.

If you have to look online the brand is Penn Plax (Cascade?) model 700.
 
  • Like
Reactions: FreshyFresh

Bellaalers

AC Members
Original poster
May 19, 2020
8
0
1
61
It's possible that there is still air trapped in the filter since you recently cleaned it. Unplug the power cord and watch and see if any air bubbles rise up the output line, wait a couple minutes and plug the power cord back in. Watch the output flow to see if it has improved. You can also try tilting the canister a bit to see if any more air escapes from the filter.

If the above suggestions don't work for improving the filter flow, you will probably have to take the filter back apart and check that everything is in the correct position and try again. Don't forget to properly prime the filter with water before plugging the power cord back in to the wall outlet.
 
zoomed.com
hikariusa.com
aqaimports.com
Store