Still no nitrites

  • Get the NEW AquariaCentral iOS app --> http://itunes.apple.com/app/id1227181058 // Android version will be out soon!

Triggerman

AC Members
Original poster
Jun 2, 2003
216
0
0
57
Visit site
I started cycling my tank March 18. Today is 6weeks and one day,still no nitrites. Have kept ammonia level at 4ppm. Ph is fine. Salinity 1.023,temp 82.
I have wet/dry running,powerhead,and double biowheel for circulation. Tons of air infusion going on and warmer temp. I am using Dr Tim's pure ammonium chloride.
How long did your tank take to cycle?
 

CinnamonPearl

Professional Whovian
May 19, 2013
232
2
18
Long Island, NY
Hm, strange. Usually nitrites would start appearing by now. Try and find some seeded filter material or gravel from an established tank and stick it in your filter. Are you absolutely sure your ammonia is only 4ppm? Any higher, and the cycle will stall.
 

tanker

Josh Holloway--Be mine!!!
Sep 1, 2003
7,319
330
116
Calif. SF Bay area
Visit site
Real Name
Jessica
Cinnamonpearl:
Why are you replying now. This post is over a year and a half old. Either he quit trying or his tank has been exstablished already. I wish people stop answering post that are very old.
 

CinnamonPearl

Professional Whovian
May 19, 2013
232
2
18
Long Island, NY
Oh, I'm so sorry! I would never usually do that, I just didn't see the date. My bad, my bad.
 

Rbishop

...and over the edge.
Staff member
Dec 30, 2005
40,296
289
143
65
Real Name
Mr. Normal
Spank! Spank! :p
 

tanker

Josh Holloway--Be mine!!!
Sep 1, 2003
7,319
330
116
Calif. SF Bay area
Visit site
Real Name
Jessica
Oh, I'm so sorry! I would never usually do that, I just didn't see the date. My bad, my bad.
Sorry, to sound mean. Not mad, but no spank from me. ;)
 
zoomed.com
hikariusa.com
aqaimports.com
Store